Estructura de las funciones de Excel

Contenido de las funciones de Excel

Para insertar una función de Excel de manera correcta es necesario conocer todas las partes que la componen, de este modo conseguiremos obtener el resultado que esperamos. Si introducimos una función de Excel erróneamente es posible que obtengamos el error #¿NOMBRE? o el aviso donde aparece "Hay un problema con esta fórmula". Como sabemos que no quieres enfrentarte a estos casos vamos a repasar la estructura que tienen las funciones de Excel.

Qué son las funciones de Excel

Las funciones de Excel son cálculos matemáticos predefinidos que ha introducido Office en las hojas de cálculo para obtener resultados específicos, de manera rápida y eficaz. Se trata de ecuaciones matemáticas parecidas a las fórmulas de Excel, salvo que están predefinidas con el objetivo de realizar cálculos específicos. Los valores que componen las funciones tienen que estar escritos en el orden correcto y siguiendo las pautas de sintaxis de cada función. Existen diferentes tipos de funciones de Excel, se clasifican según la finalidad que tienen y se formulan a través de argumentos.



Los argumentos de las funciones de Excel son los valores que determinarán el cálculo matemático, los argumentos pueden especificar el rango de Excel que incluye los valores (las celdas de Excel) o el criterio que seguirá la operación matemática (el operador que tendrá).

Partes de las funciones de Excel

Ahora que ya sabemos qué son las funciones y cómo funcionan podemos especificar las partes que componen esta operación matemática.

  • Signo =. Toda fórmula y funciones de Excel comienza con el símbolo =, de este modo indicamos al programa que va a comenzar una ecuación matemática
  • Nombre de la función. El siguiente paso es redactar el nombre que recibe cada función de Excel, podemos consultar la base de datos  de Office para conocer todas las que hay. Otro opción es utilizar el asistente de Excel, cuando estamos escribiendo la función de Excel aparece un desplegable con coincidencias de palabra, incluye el nombre de la función y una pequeña descripción para conocer qué operaciones matemáticas realiza.
  • Paréntesis. Una vez introducimos el nombre de la función abrimos paréntesis e introducimos los valores de la ecuación, una vez esté completada es importante cerrar el paréntesis.
  • Argumentos. Se trata de los datos que se necesitan para realizar el cálculo, en este caso es necesario conocer las propiedades de cada función y qué argumentos tiene.  Los argumentos utilizan referencias de celdas, valores numéricos o de texto, así como operadores matemáticos (+,-,*,/). Se separan los argumentos con el símbolo de punto y como (;).

Sintaxis de las funciones de Excel

Una de las partes más importantes de las funciones de Excel es la sintaxis que la forma, hace referencia a cómo se escriben los argumentos de la función correctamente.

La sintaxis de una función determina el orden de los argumentos =nombre (argumento; argumento; argumento)

Si se conoce la sintaxis de la función de Excel podemos introducirla de manera manual, si no se conoce, es recomendable introducir las funciones con el asistente de Excel. De este modo nos aseguramos que los argumentos están correctamente definidos.

Para entender mejor qué son las sintaxis de las funciones vamos a explicar varios ejemplos:

  • La sintaxis de la función SUMA devuelve el total de una operación matemática con el operador sumatorio, sería así: =SUMA(número, número2) y su traducción sería =SUMA(1+3)
  • La sintaxis de la función BUSCARV busca un valor dentro de una columna y devuelve el valor de otra columna de referencia, en este caso se formula así =BUSCARV(valor_buscado, rango, valor_regresado, [ordenado]), que se traduce en =BUSCARV(“Excel”, A1:B9, 4)
  • La sintaxis de la función SI evalúa una condición y devuelve el valor que coincice, se formula así =SI(condición, (si_verdaddero), (si_falso))
  • ¿Te ha servido de ayuda?
  • No