SI

La función de Excel SI (IF en inglés) Evalúa una condición y devuelve un valor si la condición es verdadera y otro valor si la condición es falsa.

SI(condición, [si_verdadero], [si_falso])



¿Para qué sirve la función SI en Excel?

La función SI o función IF (en inglés) forma parte del grupo de funciones lógicas y es una de las funciones más populares en Excel. La utilizamos para efectuar comparaciones lógicas entre un valor y el resultado que espera. Este tipo de función, además, puede servir de gran ayuda a la hora de tomar decisiones en base al resultado obtenido en la prueba lógica.

¿Cuál es la sintaxis de la función SI?

Dado que la sintaxis de esta función es SI(condición, [si_verdadero], [si_falso]) los argumentos que conforman esta fórmula son los siguientes. Solo uno de ellos tiene carácter obligatorio:

  • Prueba_lógica (obligatorio): Expresión lógica que será evaluada para saber si el resultado es VERDADERO o FALSO. Este parámetro puede ser una expresión que utilice cualquier operador lógico o una función de Excel que vuelva como resultado VERDADERO o FALSO.
  • Valor_si_verdadero (opcional): El valor que se devolverá siempre y cuando el resultado de la Prueba_lógica sea VERDADERO. Este argumento puede ser una cadena de texto, números, referencias a otra celda e incluso otra función de Excel.
  • Valor_si_falso (opcional): El valor que se devolverá siempre y cuando el resultado de la Prueba_lógica sea FALSO. Este argumento puede ser una cadena de texto, números, referencias a otra celda e incluso otra función de Excel.

Ejemplos de la función SI en Excel

A continuación te presentamos una serie de ejemplos de operaciones realizadas con la función SI.

  • =SI(D2<10;"SI";"NO")

  • =SIDIAS(HOY();F2>30;C2*0,75;C2)

💡 RECUERDA: Cuando escribas cualquier texto en la fórmula de la función SI has de hacerlo entre comillas. Sin embargo, esta norma deja de existir cuando usas las palabras VERDADERO o FALSO. Tanto si usas comillas como si no, Microsoft Excel las captará y entenderá de manera automática.

  • ¿Te ha servido de ayuda?
  • No

Parámetros que permite la función SI (IF)

Para usar la función SI hay que indicar los siguientes parámetros:

  • condición (obligatorio): Condición que se evaluará para saber si es verdadera o falsa.
  • si_verdadero (opcional): Valor que se devolverá si la condición es verdadera.
  • si_falso (opcional): Valor que se devolverá si la condición es falsa.

Cálculos con la función SI (IF)

A continuación podrás encontrar algunos ejemplos de uso real de la función SI:

SI(“1<2″, “Excel”, “Total”) = Excel SI(“1>2″, “Excel”, “Total”) = Total