Cómo comparar columnas en Excel y resaltar diferentes

Resaltar diferentes en Excel

En esta guía te enseñaremos a comparar columnas en Excel y resaltar diferentes, ya sea entre dos columnas de la misma hoja de cálculo o entre dos archivos de Excel totalmente distintos. Sólo debes seguir los siguientes pasos a continuación:

  1. Selecciona la primera celda de alguna columna en blanco. En el momento de comparar dos columnas de Excel en una hoja de cálculo por lo general, se muestran los resultados en otra columna en blanco. Asegúrate de empezar por la misma fila de las dos columnas que vas a comparar.

Por ejemplo: Si las dos columnas que necesitas comparar comienzan con A2 y B2, debes seleccionar la C2.

 

2. Escribe la siguiente fórmula de comparación para la primera fila. Esta fórmula servirá para comparar A2 con B2. Cambia los valores de las celdas del Excel en caso de que tus columnas comiencen en otras celdas distintas.

=SI(A2=B2; "Coinciden";"No coinciden")

 

3. Haz doble clic en el cuadro de RELLENAR ubicado en la esquina inferior derecha de la celda, al momento de hacer dicha acción la fórmula se aplicará para el resto de las celdas de las columnas, ajustando de manera automática los valores que se utilicen para llevar a cabo la comparación.

 

4-Analiza los valores que coinciden y los que no coinciden. Los resultados te indicarán si el contenido de ambas celdas que hayas comparado son iguales o no. Este método funciona mediante cadenas de texto, fechas, números  y horas. Debes tener en cuenta que las mayúsculas y las minúsculas no se tienen en cuenta al momento de realizar la comparación, por esta razón las palabras ROJO y rojo, coincidirán.



Porqué comparar columnas de Excel

Muchas veces quizás quieras revisar registros de una columna solo si existen registros correspondientes en otra columna que contenga uno o más campos con datos coincidentes. También puedes comparar columnas y resaltar repetidos.

Por ejemplo, puede que quieras revisar los registros de empleados que han procesado al menos un pedido para determinar cuáles empleados optan para una bonificación y cuáles no.  También puede ocurrir que quieras revisar la información de contacto de los usuarios que están ubicados en la misma ciudad de un empleado, de manera que puedas hacer que coincidan los empleados con los usuarios para reuniones personales.

La finalidad de esta guía es que Excel consulte un registro en una lista o base de datos determinada y posterior a eso, extraiga un dato de otra columna para poder llevar a cabo la comparación con el registro inicial que estas consultando o buscando.

  • ¿Te ha servido de ayuda?
  • No