Cómo comparar filas de Excel

Comparar filas en hojas de excel

A la hora de trabajar con Excel, es posible que tengamos que comparar filas en nuestros libros. Ya sea porque el trabajo consiste precisamente en comparar esos datos o para evitar que el contenido esté repetido en diferentes filas de Excel y nos provoque errores, es interesante saber qué tenemos varios métodos para comparar filas de Excel de la misma hoja, el mismo libro o incluso de documentos diferentes. E igualmente importante es saber cómo hacerlo.

Comparar filas de la misma hoja

En estre primer punto compararemos dos filas de la misma hoja de Excel del mismo libro (para comparar dos filas de hojas o libros distintos sigue leyendo). Para ello, seleccionaremos la primera celda de una fila en blanco, ya que el resultado de la comparación aparecerá en una celda en blanco. Es muy importante empezar por la misma columna de las filas a comparar (si la fila a comparar empieza en A3 y A4 puedes seleccionar A2 o A5, por ejemplo).

Copia la fórmula de comparación, modificando A2 y A3 por las filas que te interese saber si coinciden o no.

=SI(A2=A3; "Coinciden";"No coinciden")

Haz doble click en rellenar (esquina inferior derecha de la celda) para que la fórmula se aplique al resto de filas que vas a comparar, ajustándose automáticamente los valores que se utilizan para la comparación.

Te aparecerán los valores que coinciden y no coinciden. Piensa que las mayúsculas no son motivo de diferencia, así que si escribes la misma palabra en mayúsculas en una fila y en minúsculas en la otra Excel te dirá que coincide.

Comparar filas de hojas de Excel

Para utilizar este método, las dos hojas de Excel deben estar en el mismo libro. Si no es el caso, pasa al siguiente punto, comparar filas de distintos libros de Excel. Además de las dos hojas de Excel cuyas filas vas a comparar, debes crear una nueva hoja en blanco utilizando el botón + que aparece en la parte inferior de la pantalla.



Sitúa el cursor en la celda A1 de la nueva hoja en blanco, y copia la siguiente fórmula de comparación:

=SI(Hoja1!A1<> Hoja2!A1; "Hoja1:"&Hoja1!A1&" vs Hoja2:"&Hoja2!A1; "")

En la esquina inferior derecha de la celda, haz click en Rellenar y arrástralo hacia la derecha, hasta la última columna. Por ejemplo, si las dos filas a comparar tienen 20 columnas debes arrastrar el cuadro de relleno hasta la 20ª columna de ambas filas. Debes cubrir todas las celdas a comparar.

Una vez completada la operación, te aparecerán las similitudes y diferencias de las celdas de ambas hojas. La fórmula indica el valor de la celda en la primera hoja y el que tiene en la segunda hoja, si no aparece nada es que el contenido es idéntico o que la celda está vacía en la hoja original.

Comparar filas de distintos libros
Abre el primer libro de Excel, y tras activar Ver en paralelo, el segundo. De esta forma podrás avanzar a la vez en ambos libros, que compartirán pantalla. Para ello ves a Ver > Ver en paralelo > Organizar todo para decidir si los quieres ver en vertical, en horizontal, etc. Controlarás los dos libros a la vez.

De esta manera, a medida que avanzamos en las hojas de Excel podremos comprobar de forma visual las distintas filas de cada Excel. Por desgracia, no tenemos una fórmula como en los dos métodos anteriores, pero es manera más simple de comparar filas de distintos libros de Excel. Para deshabilitar la función, hay que ir a Vista > Desplazamiento sincrónico y la deshabilita.

  • ¿Te ha servido de ayuda?
  • No