Cómo usar Buscarv en varias hojas de Excel

buscarv excel hojas diferentes

Hoy te explicamos una herramienta sencilla de Excel con la que se puede obtener información de nuestro archivo de una forma muy ágil. Se trata de la función BuscarvPor lo general, no se recomienda consolidar los datos en una sola hoja de Excel antes de utilizar la herramienta Buscarv. Sin embargo,  si por alguna razón esto no es posible y no tienes otra opción que utilizar la función Buscarv en diferentes hojas de Excel, presta atención a la siguiente alternativa que mostraremos en este artículo.

Como ya sabes, usar Buscarv en varias hojas de Excel genera el error #N/A cuando no se encuentra el valor que se está buscando. Por esa razón debemos contar con la función Buscarv en la primera hoja de Excel. Si esto no funciona, te mostramos qué hacer.

Pasos para usar Buscarv en varias hojas de Excel

Esta herramienta sea una de las más útiles de Excel porque que nos ayuda a extraer los datos de una tabla o lista de datos de manera rápida y sencilla. Usar Buscarv en varias hojas de Excel es una herramienta muy fácil de utilizar, y a pesar de que cuenta con distintos pasos a seguir, una vez los hayas comprendido te resultará totalmente práctica. A través de este ejemplo sobre buscar en un libro de Excel un título determinado.

  • Paso 1: como primer paso, vamos a realizar una búsqueda sobre las dos primeras tablas.
  • Paso 2: a continuación abriremos una nueva hoja de Excel donde realizaremos la búsqueda del título de un libro con respecto a su código. Éste lo colocaremos en la celda B1. Para esto utilizaremos la siguiente fórmula:
=SI.ERROR(BUSCARV(B1,Hoja1!A2:B6,2,FALSO), BUSCARV(B1,Hoja2!A2:B6,2,FALSO))

Lo más importante es que resaltemos el rango de búsqueda especificado en esta fórmula en ambas funciones Buscarv. Después, haremos la referencia precisa en ambas funciones hacia la hoja de Excel donde deseamos que se haga la búsqueda.

 



 

  • Paso 3: si queremos considerar en nuestra búsqueda la información de una tercera página, la cual contiene muchos más códigos de productos, debemos utilizar de nuevo la función de SI.ERROR como segundo argumento de la primera parte SI.ERROR de tal manera:
=SI.ERROR(BUSCARV(B1,Hoja1!A2:B6,2,FALSO), SI.ERROR(BUSCARV(B1,Hoja2!A2:B6,2,FALSO),BUSCARV(B1,Hoja3!A2:B6,2,FALSO)))

Realizando esta modificación, nuestra búsqueda se extenderá hacia una tercera página y así podremos saber si el código de producto que estamos buscando se encuentra o no en ella.

 

  • Paso 4: Si quisieras incluir una cuarta página en la búsqueda, solo debes utilizar de nueva cuenta la función SI.ERROR nuevamente para validar los resultados de la tercera página.

Te puede interesar: Estos son los errores más habituales al usar fórmulas de Excel y sus soluciones

No obstante, debemos tener en cuenta que las versiones del programa Excel 2007 y 2010 nos permite la opción de anidar hasta 64 funciones: ese sería el límite máximo de hojas que se pueden incluir mediante este método. Sin embargo, no es recomendable alcanzar ese límite ya que con tan solo agregar una o dos funciones anidadas incrementamos la complejidad de nuestra fórmula.

Cómo enlazar hojas de Excel

  • ¿Te ha servido de ayuda?
  • No