Las fórmulas de Excel para contar caracteres

Cómo contar caracteres con fórmulas en Excel

Excel es una hoja de cálculo que nos permite realizar determinadas tareas de una manera más fácil. En este artículo te enseñaremos a utilizar la función =LARGO,   útil para contar y determinar la cantidad de caracteres que se encuentran en una celda incluyendo letras, números, caracteres especiales y hasta espacios en blanco.

Función y fórmulas para contar la cantidad de caracteres que contiene una determinada celda de Excel

 

Por ejemplo en una celda tiene una palabra o un grupo de palabras y queremos saber cuántas letras, signos, números y espacio se encuentran dentro de la celda antes dicha, podemos usar la Función =LARGO(A1) y obtener el número exacto de la cantidad de caracteres que tenemos en la celda, donde (A1) es la celda donde se encuentra los caracteres deseados para contar.

Veamos un ejemplo donde contemos los caracteres manualmente para tener una idea más clara.

Como podemos ver en la imagen anterior esta celda contiene tres palabras que en total tienen 10 caracteres. Tenemos en la celda A2 “El es Pepe”  y en la celda A4 contamos manualmente la cantidad de caracteres que tenemos solo para que tenga una referencia. El recuadro rojo nos indica en carácter y su posición. Vemos que el carácter número 6 es un espacio en blanco y el carácter número 10 es la última letra “e”.

Este función de Excel no solo cuenta letras, números y espacios, también sirve para contar caracteres especiales. Veamos a continuación un ejemplo.



Como puedes ver en este ejemplo vemos que son 10 caracteres en total y en la posición 7 se encuentra el símbolo del dólar “$” y en la posición 10 tenemos un punto (.).

No solo podemos contar una celda, también podemos hacer la sumatoria de varias celdas (fórmula para sumar en Excel) para determinar el total de caracteres que se encuentran en ese grupo de celda.

Teniendo por ejemplo tres celdas en las que cada una tiene un contenido nos dirigimos a una celda en blanco que es donde hagamos la formula de Excel. En este caso usaremos dos funciones la primera es la función SUMA (Esta nos hará la sumatoria de las celdas que deseamos que son las celdas A2; A3 y A4) esta función será combinada con la función LARGO esto nos dará el resultado deseado.

=SUMA(LARGO(A2);LARGO(A3);LARGO(A4))

¿Para que es útil contar caracteres en Excel?

Muchas web en Internet tienen límites en la cantidad de caracteres, como es el caso de Twitter. También encontraremos sitios donde te piden una cantidad de caracteres para insertar tu dirección o tu clave  por decir algún renglón. Con estas fórmulas de Excel podremos realizar textos que contengan los caracteres marcados.

Fórmulas de Excel básicas

  • ¿Te ha servido de ayuda?
  • No