Cómo ordenar los datos en Excel mediante fórmulas

Ordenar alfabéticamente las hojas de Excel

Como bien sabrás, tenemos un montón de formas de ordenar los datos de nuestros Excel. Una de las más comunes es utilizar los botones de ordenación que aparecen en la barra de herramientas para ordenarlos de forma ascendente o descendente, pero también podemos utilizar la función Ordenar para hacerlo por orden alfabético o alfanumérico. Y también podemos ordenar los datos de Excel utilizando fórmulas, una opción que también es muy sencilla y nos ofrece interesantes opciones para trabajar de forma más cómoda y eficiente con nuestros Excel.

Fórmulas para ordenar datos numéricos

Empezaremos con una fórmula fácil, para ordenar dos columnas, una de texto y otra con números, por orden numérico. En ese caso, necesitaremos recurrir a la función JERARQUIA.EQV (para las versiones anteriores a 2010 es JERARQUIA). La fórmula obtiene las posiciones de los números en un rango, y debes ajustarla al rango a ordenar. Por ejemplo, para ordenar un rango C3:C8 utilizamos la fórmula =JERARQUIA.EQV(C3,$C$3:$C$8). Junto a cada columna aparecerá el número con la posición que le correspondería.



Para completar la operación recurriremos a las funciones INDICE y función COINCIDIR de Excel, que nos permitirán ordenar en orden ascendente los datos. Siguiendo el mismo ejemplo, y entendiendo que en la columna D aparecen los resultados de la fórmula anterior, aplicamos la fórmula =INDICE($C$3:$C$8,COINCIDIR(E2,$D$3:$D$8,0)) para que los datos se ordenen a partir de la columna E. Recuerda que tendrás que editar la fórmula según el rango que quieras ordenar, indicando la celda de inicio y fin del rango.

¿Qué pasa si hay dos números iguales?

En caso de empate, Excel reconocerá que hay dos números iguales y a la hora de ordenar se saltará una posición. Por ejemplo, si hacemos una clasificación de ventas y el 4º y 5º vendedor vendieron lo mismo pasaremos del 4º al 6º. Un pequeño error, ya que uno de los vendedores no aparecerá en la tabla. Para deshacer estos problemas lo mejor es utilizar una columna auxiliar en la que apliques las fórmula =A1+0.000001*FILA() -editando siempre los rangos- que deshaga los empates sin afectar tus valores añadiendo una millonésima a cada valor.

Fórmulas para ordenar texto

La cosa cambia si en vez de cifras vamos a ordenar palabras o cadenas de palabras, para lo que recurriremos a la función CONTAR.SI y a la fórmula =CONTAR.SI($A$1:$A$5,"<="&A1. En este caso, tendremos que editar el rango -esta fórmula sirve para el rango A1:A5- y también puedes cambiar el símbolo <, que ordena por orden alfabético, por el símbolo > para ordenar tus datos de la Z a la A.

En el hipotético caso de tener dos celdas de Excel con el mismo texto nos pasará lo mismo que si tenemos dos números idénticos, Excel hará desaparecer una de ellas del nuevo orden aunque se saltará su puesto en la clasificación. Para subsanar este pequeño error volveremos a recurrir a una columna auxiliar, donde la fórmula =CONTAR.SI($A$1:$A$5,"<="&A1) + 0.000001*FILA() nos permite deshacer ese empate sin que el valor de los datos de la celda se vea afectado. Por último, utilizamos la fórmula JERARQUIA.EQV que hemos visto en el punto anterior y los datos se ordenarán perfectamente.

  • ¿Te ha servido de ayuda?
  • No