¿Cómo evitar el cero en una hoja de Excel?

Evitar errores con el numero 0 en excel

En el colegio, a todos nos enseñaron eso de que el cero no tiene ningún valor, y que su presencia en las operaciones tenía poca incidencia, por no decir ninguna. Sin embargo, la cosa cambia cuando nos vamos a Excel, ya que el cero juega un papel muy importante en el programa de cálculo de Office así que tendrás que aprender a evitar el cero en Excel si no quieres que aparezca el error #¡DIV/0!. Se trata de un error que aparece en algunas operaciones, en especial cuando hay una división y una celda está en blanco o tiene un valor 0.

Cómo corregir el error #¡DIV/0!

Antes de empezar a buscar soluciones más complejas, podemos probar con lo simple. Y lo más fácil sería comprobar visualmente nuestra hoja de cálculo para asegurarnos de que el divisor de la función o fórmula ni está en blanco ni es 0. Otro cosa que podemos hacer es cambiar la referencia de celda de la fórmula a otra que no contenga el valor cero ni esté en blanco; y por último puedes escribir #N/A en la celda de Excel donde se hace referencia al divisor de la fórmula. El resultado indicará que el valor del divisor no está disponible.

Sin embargo, nos encontramos con situaciones donde el error #¡DIV/0! aparece porque las fórmulas de Excel están esperando la entrada del usuario o de otra persona. El mensaje de error aparecerá igualmente, así que tendremos que recurrir a los diferentes métodos de control de errores que nos permiten suprimirlo a la espera de que se produzca esa entrada que nos permita eliminar el fallo y tener el documento sin ese cero. Las funciones SI y SI.ERROR nos ofrecen la solución, aunque con SI.ERROR no evitamos el cero en Excel.

La herramienta más rápida y sencilla de solucionar el error #¡DIV/0! de nuestros documentos de Excel es con la función SI, que utilizaremos para evaluar la existencia de un denominador. Si este denominador es 0 o no es ningún valor, el resultado de la fórmula será 0, o quedará en blanco, en vez de aparecernos el error #¡DIV/0!. Así, en el caso de que el error esté provocado por la fórmula =A2/A3 podemos utilizar la fórmula =SI(A3,A2/A3,0) para que aparezca 0 en vez del error.



Sin embargo nuestro objetivo era eliminar el cero en Excel, por lo que podemos utilizar la fórmula =SI(A3,A2/A3,””) para que el resultado sea una cadena vacía, sin ningún cero ni mensajes de error. Una tercera opción con la función SI sería la formula personalizada =SI(A3,A2/A3,”Entrada necesaria”). De cara al futuro, puedes añadir también la función COCIENTE, con la que indicamos a Excel que cuando exista el cociente se calcule el resultado de la fórmula. Si no es así, se ignorará.

La otra opción que tenemos de eliminar el error #¡DIV/0! es con SI.ERROR, pero como hemos dicho antes no eliminamos el cero, sino que hacemos que el resultado sea 0 en vez de #¡DIV/0! Lo único que tienes que hacer es utilizar la fórmula correcta, por ejemplo =SI.ERROR(A2/A3,0), o =SI(ESERROR(A2/A3),0,A2/A3) si utilizas una versión previa a Excel 2007. En cualquier caso, lo que hace es evaluar la fórmula como error al no obtener todos los datos y nos devuelve el 0.

Ver más: Estos son los errores más habituales al usar fórmulas de Excel y sus soluciones

Cómo eliminar el valor 0 de Excel

Por último, vamos a ver cómo eliminar el valor 0 en Excel. Selecciona el rango donde están los valores 0 y sigue el itinerario Inicio > Formato condicional > Nueva regla de formato y a las celdas con el valor 0 les damos el mismo color que al fondo de la celda, de forma que quedan ocultos. Si quieres, también puedes personalizar el formato para suprimir los ceros, pero esta es la forma más útil de eliminar el valor de todas las celdas que den como resultado 0 de tu Excel.

¿Quitar o poner ceros en Excel es posible?

  • ¿Te ha servido de ayuda?
  • No