SUMAR.SI

La función de Excel SUMAR.SI (SUMIF en inglés) Suma los valores de un rango siempre y cuando cumplan con las condiciones especificadas.

SUMAR.SI(rango, condición, [rango_suma])

¿Para qué sirve la función SUMAR.SI?

Aunque quieras sumar valores en tus informes, es posible que no quieras sumar TODOS los valores de la operación o que solo desees tener en cuenta los valores que cumplen un criterio especificado. Por ello, la función SUMAR.SI es perfecta para realizar una suma restringiendo la operación a determinadas cifras.

💡 SUMAR.SI combina las funciones SUMAR y SI. ¿Qué quiere decir esto? Que aunque puedes usar las funciones SUMAR y SI al mismo tiempo en una fórmula, conseguirás el mismo efecto si utilizas únicamente la función SUMAR.SI. De esta manera el trabajo con sumas será mucho más sencillo.

Fórmula de la función SUMAR.SI en Excel

Siempre que quieras incluir esta función en tu Excel debes anotar las siguientes fórmulas (dependiendo de si las ponemos en español o inglés):

🇪🇸 =SUMAR.SI(rango, criterio, [rango_suma])

🇬🇧 =SUMIF(rango, criterio, [rango_suma])



Sintaxis de la función SUMAR.SI en Excel

La sintaxis de esta función está conformada por dos argumentos obligatorios (rango y criterio) y uno opcional (Rango_suma):

  • Rango (obligatorio): El rango de celdas que quieres evaluar según los criterios establecidos. En este parámetro introduces las celdas a las que se debe aplicar el criterio; unas celdas en las que aparecen números o valores.
  • Criterio (obligatorio): Es el criterio en forma de número, texto o referencia de celda que determina las celdas que se van a sumar. En los criterios pueden emplearse:
    • Signo de interrogación (?): Para hacer coincidir cualquier carácter individual.
    • Asterisco (*): Para hacer coincidir cualquier secuencia de caracteres.
    • Tilde (~): Si deseas buscar el signo de interrogación o el asterisco en la fórmula.
  • Rango_suma (opcional): Las celdas reales que se sumarán (siempre y cuando, por supuesto, desees sumar celdas a las ya especificadas en el argumento rango).

Ejemplos de la función SUMAR.SI en Excel

  • =SUMAR.SI(A2:A10;">=1000"): En este caso concreto sumamos los valores que hay desde la celda A2 a la celda A10 con un valor mayor o igual a 1000.

  • =SUMAR.SI(A2:A15;"Adam";B2:B15): Con este ejemplo hacemos referencia a otras celdas y sumamos todos los importes de dinero que han sido ingresados por Adam.

  • =SUMAR.SI(A2:A15;$D$2;B2:B15): En este caso también puedes establecer una referencia a una celda en la que aparezca el resto de nombres.

❌ La función SUMAR.SI puede devolver resultados incorrectos si se utiliza para comparar cadenas largas de más de 255 caracteres.

  • ¿Te ha servido de ayuda?
  • No

Parámetros que permite la función SUMAR.SI (SUMIF)

Para usar la función SUMAR.SI hay que indicar los siguientes parámetros:

  • rango (Obligatorio): El rango de celdas a las que se le aplicará la condición de suma.
  • condición (Obligatorio): La condición que se debe de cumplir para ser tomado en cuenta para la suma.
  • rango_suma (Opcional): El rango de celdas que será sumado. Si es omitido se sumarán los valores del primer argumento.

Cálculos con la función SUMAR.SI (SUMIF)

A continuación podrás encontrar algunos ejemplos de uso real de la función SUMAR.SI:

SUMAR.SI(A1:A5,”>3″) = Suma los valores en A1:A5 que sean mayores a 3 SUMAR.SI(A1:A5,”>3″,B1:B5) = Suma los valores en B1:B5 siempre y cuando los valores en A1:A5 sean mayores a 3