Cómo buscar en varios libros de Excel a la vez

buscar entre varios libros excel

Si utilizas varios libros de Excel es fácil que tarde o temprano olvides dónde estaba ese dato que necesitas ahora mismo. Nuestra memoria no es infalible, y seguro que lo recordamos en el momento más inesperado, pero cuando nos preguntamos dónde estaba ese dato en concreto y somos incapaces de recordarlo acabamos desesperados. A continuación vamos a ver cómo buscar en varios libros de Excel un dato, una búsqueda muy fácil que cualquier usuario de este programa debería conocer. Más cuando la ayuda en línea (F1) solo nos da instrucciones para búsquedas en una hoja o en un solo libro, pero no dice nada sobre varios libros.

Búsqueda por celdas de Excel

Para poner en marcha esta búsqueda, será imprescindible que tengas abiertos los libros de Excel en los que sospeches que puede esconderse el dato. Nos servirá para tantos libros como haya abiertos, así que no tengas miedo de abrir un montón de libros de Excel a la vez. Cuando hayas abierto todos los libros de Excel basta con escribir el dato que quieres encontrar en una celda del libro que aparezca en primer plano. Realmente no importa qué libro aparece más arriba.

Con el ratón, elige el rango en otro libro. Te aparecerá una fórmula similar a =BUSCARV(A2;[Libro2.xlsx]Hoja1!$A$1:$D$8;2;FALSO)

El nombre del otro libro es lo que aparece entre corchetes. Al cerrar el segundo libro, la fórmula te mostrará entre comillas la ruta directa hasta el archivo donde están esos datos que buscabas. El resultado será algo parecido a esto: =BUSCARV(A2;'C:\Users\tunombredeusuario\Documents\loquesea\[Libro2.xlsx]Hoja1'!$A$1:$D$8;2;FALSO)



Al abrir el libro de Excel donde está el vínculo externo, Excel te preguntará si quiere o no actualizar los vínculos. Si aceptas, se abrirán internamente el resto de libros y Excel buscará el valor que quieres buscar en todos ellos.

Búsqueda en Excel a través de Windows

Sí, también puedes buscar datos en varios libros de Excel a la vez a través de Windows. Si sabes en qué carpeta están los libros pero no en qué libro en concreto está ese dato que necesitas saber ahora mismo, en vez de abrir todos los libros uno a uno y buscarlo, lo que te llevará bastante tiempo si la suerte no te sonríe y te aparece en el primer libro, puedes escribir el dato exacto en el buscador de Windows, que suele aparecer en la esquina superior derecha.

Te aparecerán los resultados de la búsqueda, así que si has afinado tendrás ante ti el documento con el dato que buscas. Basta con abrir el libro de Excel para comprobar que la búsqueda ha sido un éxito. Si no has conseguido el resultado esperado prueba con una búsqueda más precisa, como varias palabras exactas en vez de una sola, o si has afinado demasiado y no obtuviste resultados con una búsqueda algo más genérica.

Cómo abrir varios libros de Excel en ventanas separadas

  • ¿Te ha servido de ayuda?
  • No