Contar registros únicos en tablas dinámicas de Excel

importancia excel formacion secretarias

Al hacer tablas dinámicas podremos contar los valores únicos llevando a cabo varios pasos y emplearemos algunas funciones de Excel para contar registros únicos en tablas dinámicas de Excel. Si incluimos la ciudad tanto en el rótulos de fila como en valores, realizará la cuenta de registros de manera automática pero no contará aquellos valores únicos.

Contar valores únicos en tabla dinámica

Antes de contar los registros únicos de la tabla dinámica realizaremos un recuento general de las ciudades. Para ello, tendremos dos columnas nombre y ciudad e insertaremos la tabla dinámica incluyendo el campo ciudad en los rótulos de la fila y en valores.



Cómo contar registros en Excel

  • Para realizar el recuento de registros únicos emplearemos una fórmula concreta combinando la función SUMAPRODUCTO y la función SI. Añadiremos la columna valores únicos y escribiremos la siguiente fórmula: =SI(SUMAPRODUCTO((B$2:B2=B2)*1)>1;0;1)
  • A continuación, insertaremos la tabla de Excel seleccionando la columna ciudad y valores únicos, obteniendo el siguiente resultado.

Cómo contar registros únicos en tablas dinámicas de Excel

Ejercicios de Excel con tablas dinámicas de datos

  • ¿Te ha servido de ayuda?
  • No