Y

La función de Excel Y (AND en inglés) Regresa el valor VERDADERO si todos los parámetros son verdaderos ó regresa FALSO si alguno de los parámetros es falso.

Y(valor_lógico1, [valor_lógico2], …)



La Función Y es una función de Excel que comprueba si se cumplen dos o más pruebas lógicas. Devuelve VERDADERO si se cumplen todos los parámetros y FALSO en caso de que alguno no se cumpla.

Sintaxis de la Función Y o AND en Excel

La Función Y es una de las funciones lógicas de Excel y se calcula aplicando la siguiente fórmula:

=Y (valor_lógico1; valor_lógico2)

Podemos añadir tantos parámetros como queramos agregándolos por orden separados por ";". Se pueden colocar entre 1 y 255 pruebas lógicas. Donde:

  • valor_lógico1 (Obligatorio): esta prueba puede ser desde una desigualdad matemática, B3>=1, hasta una prueba de cadenas o más complejo: LARGO(A2)>7. Esta prueba lógica será VERDADERO si se cumple y FALSO en caso contrario.
  • valor_lógico2 (Opcional): podemos usar tantos parámetros como queramos (hasta 255).

Una de las principales funciones de la función Y y la función O es utilizarla de prueba lógica para la función SI.

Usar la función Y o AND en Excel: ejemplos prácticos

A continuación, mostramos algunos ejemplos generales del uso de Y por sí mismo y junto a la función SI:

  • Si usamos la fórmula =Y(A2>1,A2<100), observamos que muestra VERDADERO si A2 es superior a 1 Y es inferior a 100; de otra forma, muestra FALSO.
  • Si utilizamos la fórmula =SI(Y(A2<A3,A2<100),A2,"El valor está fuera del rango"), muestra el valor de la celda A2 si es inferior a A3 Y es inferior a 100, de otro modo muestra el mensaje "El valor está fuera del rango".
  • ¿Te ha servido de ayuda?
  • No

Parámetros que permite la función Y (AND)

Para usar la función Y hay que indicar los siguientes parámetros:

  • valor_lógico1 (obligatorio): Primera condición a probar.
  • valor_lógico2 (opcional): Condiciones adicionales a probar.

Cálculos con la función Y (AND)

A continuación podrás encontrar algunos ejemplos de uso real de la función Y:

Y(VERDADERO, VERDADERO) = VERDADERO Y(VERDADERO, VERDADERO, FALSO) = FALSO