CONTAR.SI



La función CONTAR.SI (COUNTIF en inglés) es un tipo de función estadística que se utiliza para contar el número de celdas dentro de un rango que cumplan con el criterio que se haya especificado en el segundo argumento de la función; como por ejemplo el número de veces que un artículo concreto aparece en una lista de compradores. La fórmula de esta función de Excel es =CONTAR.SI y su significado más explícito podría ser: ¿Dónde quieres realizar la búsqueda y qué quieres buscar?

Sintaxis de la función CONTAR.SI en Excel

La función CONTAR.SI cuenta con dos únicos argumentos:

  • El rango (obligatorio) es el argumento que contiene los valores que se desean contabilizar; es decir, el argumento del que se desea contar el número de celdas en Excel que NO están en blanco.
  • El criterio (obligatorio) es la condición que determina las celdas que serán contadas por la función; es decir, la condición que debe cumplir para ser incluido en la cuenta.

Ejemplos de la función CONTAR.SI en Excel

  • =CONTAR.SI(B2:B11, "azul")

  • =CONTAR.SI(B3:B17;"10969")

Consejos para calcular con la función CONTAR.SI

Para evitar cualquiera de los errores más habituales en Excel te recomendamos que sigas las indicaciones del mismísimo servicio de soporte de Microsoft Office para la función CONTAR.SI:

  • Los criterios de la función CONTAR.SI no distinguen entre mayúsculas y minúsculas. Así pues, el resultado de la cadena "relojes" y el resultado de la cadena "RELOJES", por poner un ejemplo, dará como resultado la misma cantidad de celdas.
  • Usa caracteres comodín en los criterios. ¿Y cuáles son estos caracteres? El signo de interrogación (que reemplaza cualquier carácter individual) y el asterisco (que sustituye cualquier secuencia de caracteres).
  • Dado que la función CONTAR.SI admite rangos con nombre en la fórmula no dudes en utilizarlos. De esta manera te será mucho más cómodo e ilustrativo averiguar la cifra que necesitas.
  • Asegúrate de que los datos no contengan caracteres incorrectos porque la función CONTAR.SI podría devolver un valor inesperado o incorrecto. Caracteres a los que deberías prestar especial atención puesto que suelen ser conflictivos: las comillas rectas y tipográficas.

💡 Si Excel te ha devuelto un valor incorrecto para una cadena larga (es decir, para comparar cadenas de más de 255 caracteres) te recomendamos que utilices la función CONCATENAR en lugar de CONTAR.SI. De esta manera te asegurarás de obtener los resultados adecuados.

  • ¿Te ha servido de ayuda?
  • No