Cómo calcular las horas en Excel

Calcular en Excel las horas
Plantilla de recursos humanos para excelVer plantilla premiumVer plantilla premium

Una de las muchas posibilidades que nos ofrece Excel es calcular las horas, algo muy útil en especial cuando se trata de calcular las horas que hemos trabajado, las horas extra, etc. Muchas veces tendremos que recurrir a fórmulas y funciones de Excel, algo que no todos los usuarios dominan, así que vamos a descubrir cómo calcular las horas extra, horas negativas y horas trabajadas en Excel con diferentes fórmulas y funciones.

Calcular Excel horas extra

Si quieres calcular tus horas extra o las de uno de tus empleados, puedes acudir a Excel para ello. Necesitarás una tabla con las horas de entrada y salida, y otra con las horas de trabajo y las de descanso. Haz una tabla con los encabezados fecha, hora de entrada, hora de salida y total horas, en la que también puedes introducir la hora de inicio y fin de descanso. De esta forma calculas las horas de trabajo, y a partir de ahí puedes calcular las horas extra en Excel, pero también las regulares que has trabajado.

Para el cálculo de las horas extra, suponiendo que en B6 tenemos el número de horas diarias que trabajamos y en F10 el número de horas totales de un día utilizamos la fórmula condicional =SI(F10>$B$6,F10-$B$6,0), fórmula a insertar en la celda donde queremos obtener el resultado con las horas extra que hemos trabajado. Si tienes una tabla con varios días tendrás que repetir el camino modificando las horas totales del día, en este caso F10. A partir de ese resultado podemos calcular el sueldo que nos corresponde por horas extra.



Nómina con horas extra

Calcular Excel horas negativas

Un problema muy habitual al trabajar con horas en Excel es que cuando el resultado son horas negativas aparece ########, una serie de almohadillas fruto de un error del programa. Calcular en Excel las horas negativas nos puede servir, por ejemplo, para calcular las horas que hemos trabajado de menos un día o una semana para compensar las horas extra. La primera solución es cambiar el sistema de fechas 1900 a 1904, a través del itinerario Opciones de Excel > Opciones avanzadas > Al calcular este libro, donde activamos la casilla Usar sistema de fechas 1904 y pulsamos Aceptar.

La otra alternativa es recurrir a la función TEXTO de Excel, con una fórmula similar a =SI(A2< B1;"-"&TEXTO(B1-A2;"hh:mm:ss");TEXTO(A2-B1;"hh:mm:ss")), adaptada siempre a nuestro rango de datos. Lo que hace la función es, en el caso de que B sea mayor que A, restarle el número menor y añadir el símbolo – antes del resultado. Cuando B es menor le resta el número mayor, y el resultado siempre es negativo. De esta forma podemos calcular las horas negativas en Excel.

Calcular Excel horas de trabajo

Como bien sabrás, Excel es capaz de identificar los días laborables así que nos será muy fácil calcular las horas que hemos trabajado. Lo único que necesitamos es una tabla con el horario de entrada y salida, que aparece en las celdas B2 y B3 en el ejemplo que vamos a ver, y una fecha inicio y de fin del periodo al que le vamos a calcular las horas , por ejemplo en las celdas B5 y B6 respectivamente.

Una vez tenemos los datos, para calcular las horas de trabajo utilizamos la fórmula =(DIAS.LAB(B5,B6) - 2) * (B3-B2), adaptada siempre a los datos que tengas. Por una parte, la función DIAS-LAB nos calcula los días laborables en el lapso temporal que hay entre la fecha de inicio (B5) y la de final (B6); y por otra parte nos encontramos con que, una vez calculados los días laborables, se multiplica por las horas trabajadas, la resta de la hora de salida (B3) a la de llegada (B2).

  • ¿Te ha servido de ayuda?
  • No
Plantilla de recursos humanos para excel

Dashboard Premium Recursos Humanos

Con esta plantilla de Excel podrás llevar el control total de los recursos humanos de tu empresa: individualmente, por departamento y realizar una comparativa general interanual. También podrás analizar la información más relevante por departamento del último año: número de empleados, salario total, bonos recibidos, salario promedio, permisos de enfermedad y el promedio de ausencias por enfermedad. Con esta plantilla de Excel podrás visualizar de un simple vistazo la información más relevante con respecto a la gestión de RRHH en un periodo dado: la variación de empleados por año, cuánto personal hay por cada departamento, distribución salarial, detalles de las nóminas. También podrás analizar el detalle de cada empleado de forma independiente. ¡Conoce la plantilla de Excel más completa para RRHH!Saber más

$23,35 $11,09 Sin impuestosAñadir al carrito

Plantilla Premium Control de Horario Laboral y Gestión de Vacaciones

Os presentamos la mejor plantilla de Excel para gestionar a tus empleados. Esta herramienta te permitirá realizar el control horario de la jornada laboral y gestionar las vacaciones y ausencias de todos tus empleados en un solo documento. Esta plantilla contiene todo lo que necesitas para optimizar la gestión de los recursos humanos de tu empresa y cumplir con la ley de registro de jornada laboral en España. Podrás registrar los fichajes diarios y exportar el horario laboral de cada empleado en PDF. También te permite registrar la política de vacaciones de la empresa y controlar la presencia laboral. Genera automáticamente el organigrama de tu organización o de cada departamento. ▶ VER VÍDEO DEMOSTRATIVO   Saber más

$75,88 $64,21 Sin impuestosAñadir al carrito