¿Por qué utilizar referencias estructuradas en Excel?

Referencias estructuradas en Excel

Excel facilita la realización de cálculos, ya sean simples o complejos, sus amplias funciones nos ayudan a realizar todo tipo de operaciones. Entre los recursos que podemos utilizar para agilizar los cálculos se encuentran las referencias de Excel, son llamadas al contenido de una celda o un conjunto de celdas. La gran ventaja de este sistema es que la fórmula matemática que introducimos se actualiza automáticamente al modificar los datos de la celda original. Las referencias son un gran recurso de las hojas de cálculo, existe las referencias de Excel aplicadas una celda y referencias aplicadas a una tabla completa o parcial, esto se conoce como referencia estructurada.

¿Qué son las referencias estructuradas en Excel?

Se trata de un recurso muy interesante para incluir como valor en la fórmula matemática, en este caso es el resultado que obtenemos de una tabla.  Es decir, la referencia estructurada se utiliza en la formulación incluyendo el resultado total o parcial de una tabla de Excel.

La referencia estructurada es la combinación entre la tabla y las columnas que la componen , siendo el nombre un elemento imprescindible en la utilización de este estilo de referencias en Excel. La referencia a una celda se muestra así: =SUMA(C2:C7), sin embargo la referencia a una tabla quedaría así: =SUMA(Tabla1[Beneficios]), aunque a simple vista parezca un elemento complejo lo cierto es que es muy fácil de implementar.

Cómo se utiliza la referencia estructurada en Excel

La referencia estructurada utiliza el nombre de la tabla, así como el nombre de las columnas, como argumentos de la fórmula, por este motivo el primer paso es nombrar correctamente la tabla o saber cómo se llama. En la herramienta de diseño de la tabla encontraremos cómo se llama la tabla, podemos modificarlo si así lo deseamos. El nombre de las columnas es el que aparece en la fila de encabezado de la tabla.

Ahora que ya sabemos cómo se llama la tabla podemos utilizarla en la referencia estructurada de las fórmulas. Si quisiéramos sumar el total de una columna de la tabla podríamos utilizar la fórmulas con el operador sumatorio =B2+B3+B4+B5+B6+B7, también podemos usar la función SUMA del programa =SUMA(B2:B7), o podemos usar la referencia estructurada de la columna VENTAS =SUMA(Tabla1[VENTA])



Para llegar hasta ese argumento solo tenemos que seguir estos pasos:

  1. Como usar las referencias estructuradas en ExcelEn la celda donde queremos obtener el total escribimos la fórmula SUMA 
  2. A continuación abrimos paréntesis y empezamos a escribir el nombre de la tabla. Veremos cómo aparece automáticamente como sugerencia.
  3. Después indicaremos la columna exacta de la tabla que queremos aplicar la fórmula, para ello abrimos corchetes y escribimos el nombre de la columna. En este caso también aparecerán las posibles opciones que existen
  4. Por último apretamos intro y obtendremos el resultado esperado

Motivos para usar referencias estructuradas en Excel

Las referencias estructuradas nos van a permitir trabajar de manera ágil y eficiente, aunque su formulación parezca más compleja el resultado es más certero que si escogemos rangos de celdas. Si la tabla va sufrir modificaciones sabremos al 100% que los resultados de nuestra fórmula incluyen todas las nuevas filas o columnas que se han añadido a la tabla. Es el fin de ajustar de manera manual los rangos de Excel que se aplicaban a las fórmulas.

Podemos usar este tipo de referencia tanto en fórmulas como en funciones de Excel y ello supone asegurarse los resultados. No es necesario ajustar los rangos de celdas y tampoco asegurarse que la celda marcada es la correcta, pues el nombre de la tabla aparece en la propia fórmula y nos da pistas de qué incluye.

Inicialmente supone aprender la sintaxis de las referencias estructuradas, pero a la larga nos permite agilizar las operaciones matemáticas y por eso se recomienda su uso.

  • ¿Te ha servido de ayuda?
  • No