INDIRECTO

La función de Excel INDIRECTO (INDIRECT en inglés) Obtiene el valor de una celda cuya referencia es especificada como texto.

INDIRECTO(ref, [a1])

Esta función de Excel puede ser utilizada para crear una referencia que no cambia aún cuando se insertan filas o columnas en la hoja de Excel. Pero también se puede utilizar para crear una referencia a partir de una letra o número, dando forma a la dirección de la celda de la cual deseamos obtener la referencia.

De esta manera, la función INDIRECTO permite extraer una referencia de otra celda. De esta manera, los usuarios pueden componer sus propias referencias de celda tomando la primera mitad de una y la segunda de otra. Entonces, en la celda en la que se utiliza el INDIRECTO aparece el valor al que remite la segunda referencia.

En la mayoría de ocasiones la función INDIRECTO se utiliza en combinación con otras funciones.

Otro de sus usos es para referenciar a valores en otras hojas de cálculo. Cuando se trabajan tablas y cálculos similares dispuestos en diferentes hojas y se quieren visualizar los valores seleccionados en otras hojas en una vista general.

La función INDIRECTO y otras funciones

Como hemos comentado, es muy común utilizar esta función junto a otras. Por ejemplo, se utiliza bastante con la función SUMA para añadir valores de otra hoja de cálculo.



Por ejemplo, con la fórmula =SUMA(INDIRECTO("'"&A3&"'!B1:B5"))

En este caso, la fórmula está sumando las celdas de B1 a B5 en una hoja de cálculo que se puede determinar en la celda A1 más próxima.

Combinación de SUMA e INDIRECTO en una tabla de Excel

 

  • ¿Te ha servido de ayuda?
  • No

Parámetros que permite la función INDIRECTO (INDIRECT)

Para usar la función INDIRECTO hay que indicar los siguientes parámetros:

  • ref (obligatorio): Referencia a la celda que contiene el nombre (texto) de la celda de la cual se desea obtener el valor
  • a1 (opocional): Si es falso se interpreta como una referencia F1C1 de lo contrario se interpreta como referencia A1

Cálculos con la función INDIRECTO (INDIRECT)

A continuación podrás encontrar algunos ejemplos de uso real de la función INDIRECTO:

INDIRECTO(“A1″) = valor contenido en la celda A1 INDIRECTO(A1) = valor de la celda especificada en A1