4 elementos básicos de una fórmula que deberías conocer

Elementos de las fórmulas de excel

Excel realiza cálculos utilizando fórmulas de Excel que aplica a las celdas. Para indicarle al programa que vamos a utilizar una fórmula, debemos comenzar escribiendo un signo = en una celda o con ésta seleccionada, en la barra para funciones en la cinta de opciones.



Existen fórmulas más simples como por ejemplo = 3x5+7 ó más complejas, que incluyen dentro funciones de Excel como =SUM(A1:A10)x8.  Así, las fórmulas pueden incluir funciones, operadores, referencias y constantes. En este artículo te explicaremos qué significan cada una de estos elementos, que pueden incluir todos o sólo algunos.

Aspectos fundamentales de una fórmula de Excel

  1. Funciones: se consideran fórmulas predefinidas por Excel que realizan cálculos con los argumentos que les introducimos en un determinado orden. Así por ejemplo, la función función CONTAR, cuenta las celdas blancas en un rango. BLANCO(A1:A20) .Las funciones están formadas por los siguientes elementos:
    1. Nombre de la función, que podemos escribirlo nosotros directamente en la barra de funciones, detrás del signo =, en el caso anterior, sería CONTAR.BLANCO. Si no conocemos el nombre o no deseamos escribirlo, bastará con buscar la función en la cinta de opciones, en el grupo Fórmulas, que se encuentran ordenadas por categorías. No obstante, cuando nosotros comencemos a escribir en la barra de funciones las primeras letras de ésta, nos aparecerá un listado con funciones que comienzan por esas letras, sólo tendremos que elegir las que nos interese. Si pulsamos las teclas may+ f3 obtendremos también el cuadro Insertar función con el listado de las mismas.
    2. Argumentos, es lo que introduciremos dentro de los paréntesis y pueden ser números, textos, operadores lógicos, referencias celdas…en nuestro ejemplo de más arriba, el argumento sería el rango de celdas A1:A20, donde deberá buscar. Si una función contiene varios argumentos, éstos han de estar separados por ; como por ejemplo =SI(D8=H8; "Coinciden";"No coinciden").
    3. Paréntesis. Como hemos dicho, los argumentos van dentro de paréntesis así, detrás del nombre de función, se abrirá un paréntesis con los argumentos y la función terminará con un paréntesis.
  2. Sirven para identificar una celda o rango de celdas a las que queremos aplicar la fórmula. Se puede hacer referencias a las celdas de la misma hoja, o bien a celdas de otras hojas. La letra se refiere a la columna de Excel y el número a la fila. Algunos ejemplos de formato de referencias serían:
    1. Referencia a una celda en concreto: B5, que sería la columna b y fila 5
    2. Referencia a un rango de celdas: B5:B8
    3. Referencia a celdas de una hoja Hoja2'!$D$12

En cuanto a las referencias tenemos que distinguir también entre:

  • Referencias absolutas. Se representan poniendo el signo $ delante de la columna y la fila. Esto quiere decir que este valor se mantendrá siempre el valor de esta celda, cambie el sitio o se cambie de ubicación. $D$8
  • Referencias relativas. Es la referencia normal, sin estos signos, y lo que quiere decir es que el valor de la celda o celdas a la que se refiere, puede cambiar si se cambia de ubicación o se realizan cálculos.
  1. Constantes: son números o textos que escribimos directamente en la fórmula, no se refiere a ninguna celda como en el caso de las referencias. Por ejemplo, si queremos que Excel nos sume todas las celdas del rango A9:A34 y al resultado le sume 39, la fórmula quedaría: = SUMA(A9:A34)+39, siendo el número 39 un dato que hemos tenido que escribir nosotros, una constante.
  2. Operadores: con ellos indicamos a la fórmula el tipo de cálculo que queremos realizar. Podemos distinguir operadores de distintos tipos como 0peradores matemáticos, que son los que utilizamos para hacer cálculos básicos: +, -*, /…pero también podemos utilizar operadores de comparación como por ejemplo: = , > (mayor que), < (menor que), entre otros.

 

  • ¿Te ha servido de ayuda?
  • No