¿Cómo saber cuántas veces se repite un valor en Excel?

Google Sheets en la empresa

Existen ocasiones en las que, trabajando con un gran documento en Excel, necesitamos saber el número de veces que se repite un mismo elemento. Por suerte, no hace falta que lo hagamos a mano puesto que se trata algo muy sencillo gracias a las funciones de Excel.

Con la función CONTAR.SI podemos contar la frecuencia de un valor

Existen diferentes maneras de contar con qué frecuencia aparece un valor en un documento, pero la más común es mediante la función CONTAR.SI. Esta cuenta el número de veces que un valor específico aparece en un rango de celdas. Y su fórmula es la siguiente:

=CONTAR.SI(¿dónde se quiere realizar la búsqueda y qué se quiere buscar?)

Un ejemplo del uso de esta función estadística sería el siguiente: =CONTAR.SI(A1:A10; "42") .

 

Excel GIF

 

Antes de utilizar esta función, debes tener en cuenta lo siguiente:

  • Los criterios de la función CONTAR.SI no distinguen entre mayúsculas y minúsculas.
  • Los caracteres comodín, como las interrogaciones y asteriscos, pueden utilizarse como valores.
  • Debes asegurarte de que los datos no contienen espacios ni al principio ni al final, o que no haya un uso incoherente de las comillas, puesto que CONTAR.SI podría devolver un valor inesperado o incorrecto.

Otras maneras de saber cuántas veces se repite un dato en Excel

A parte de emplear la función CONTAR.SI, también hay otras cosas que puedes realizar como contar según varios criterios mediante la función CONTAR.SI.CONJUNTO, contar con qué frecuencia aparecen varios valores de texto o numéricos empleando las funciones SUMA y SI juntas o mediante una tabla dinámica.

CONTAR.SI.CONJUNTO

Aunque es parecida a la fórmula anterior, esta puede utilizar hasta 127 pares de rangos o criterios. Así pues, puede aplicar criterios en las celdas en varios rangos y cuenta el número de veces que se cumplen todos los criterios.

CONTAR.SI.CONJUNTO(rango_criterios1; criterios1, [rango_criterios2; criterios2];…)



SUMA y SI

La función SI prueba los valores en algunas celdas y luego, si el resultado es VERDADERO, la función SUMA calcula el valor total de todos los valores que pasan la prueba. Debes tener en cuenta que estas fórmulas deben escribirse como fórmulas de matriz.

Mediante una tabla dinámica

Esta puede utilizarse para mostrar datos totales y contar las apariciones de valores únicos en Excel. Las tablas dinámicas son una forma interactiva de resumir de forma rápida grandes volúmenes de datos. Una vez creada la tabla dinámica lo que tienes que hacer es acudir al cuadro de diálogo de "Configuración de campo de valor" y seleccionar la opción "recuento", en el campo "nombre personalizado" has de cambiarlo a "recuento" y hacer clic en "aceptar". De esta manera la tabla dinámica mostrará un recuento final.

 

Como ves, para encontrar valores repetidos en Excel solo debes elegir una de las formas anteriores, y una vez los detectes podrás eliminarlos sin ningún tipo de problema.

  • ¿Te ha servido de ayuda?
  • No